Error running expensesample.hosts.windowsservicehost.exe

Oct 4, 2008 at 5:50 AM

Running a transacted installation.

Beginning the Install phase of the installation.
See the contents of the log file for the C:\projects\ExpenseSample-20080528\bin\Debug\expensesample.hosts.windowsservicehost.exe assembly's progress.
The file is located at C:\projects\ExpenseSample-20080528\bin\Debug\expensesample.hosts.windowsservicehost.InstallLog.

An exception occurred during the Install phase.
System.Security.SecurityException: The source was not found, but some or all event logs could not be searched.  Inaccessible logs: Security.

The Rollback phase of the installation is beginning.
See the contents of the log file for the C:\projects\ExpenseSample-20080528\bin\Debug\expensesample.hosts.windowsservicehost.exe assembly's progress.
The file is located at C:\projects\ExpenseSample-20080528\bin\Debug\expensesample.hosts.windowsservicehost.InstallLog.

The Rollback phase completed successfully.

The transacted install has completed.

Oct 4, 2008 at 6:14 AM
doh... works when I run as administrator...sorry!... but now I can't see the service to start it... am I looking for "windows service host"

running a transacted installation.

Beginning the Install phase of the installation.
See the contents of the log file for the C:\projects\ExpenseSample-20080528\bin\Debug\expensesample.hosts.windowsservicehost.exe assembly's progress.
The file is located at C:\projects\ExpenseSample-20080528\bin\Debug\expensesample.hosts.windowsservicehost.InstallLog.

The Install phase completed successfully, and the Commit phase is beginning.
See the contents of the log file for the C:\projects\ExpenseSample-20080528\bin\Debug\expensesample.hosts.windowsservicehost.exe assembly's progress.
The file is located at C:\projects\ExpenseSample-20080528\bin\Debug\expensesample.hosts.windowsservicehost.InstallLog.

The Commit phase completed successfully.

The transacted install has completed

Oct 4, 2008 at 7:11 AM
OK I found the service..

But now I get 4 errors that all look a bit like this

Error 1 Unable to copy file "obj\Debug\ExpenseSample.Business.Entities.dll" to "..\bin\Debug\ExpenseSample.Business.Entities.dll". The process cannot access the file '..\bin\Debug\ExpenseSample.Business.Entities.dll' because it is being used by another process. ExpenseSample.Business.Entities

Any Ideas. I have restarted the service and even restarted the computer..
Oct 4, 2008 at 9:01 AM

Compilation Error

Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0117: 'ExpenseSample.UI.Process.SubmitterUserProcess' does not contain a definition for 'Dispose'

Source Error:

Line 45:     protected void Page_Unload(object sender, EventArgs e)
Line 46:     {
Line 47: _upc.Dispose();Line 48:     }
Line 49: 

Coordinator
Oct 10, 2008 at 12:40 AM
Edited Oct 10, 2008 at 12:41 AM
Hi!

It looks like you are trying to run the Windows Service Host and Web clients with the May release. It is documented in the "KNOWN ISSUES IN THIS PREVIEW" section of the Readme.txt that these don't work in the May release :)