Error connecting to /ExpenseService

Sep 16, 2009 at 6:20 PM
Edited Sep 16, 2009 at 6:22 PM

I get the following error when loading the web app:

Could not connect to http://localhost:8000/ExpenseService. TCP error code 10061: No connection could be made because the target machine actively refused it 127.0.0.1:8000.

Any thoughts as to what might be happening? I did change the ConnectionStrings to point to my local database.

Thanks,
Cameron Pulcifer

Sep 25, 2009 at 3:22 PM

I am running into the same issue, anyone have ideas on what is going on?'

 

Josh

Sep 25, 2009 at 4:02 PM
Edited Sep 25, 2009 at 4:04 PM

Yeah, so the link that it diplays in the error does actually fix the problem :P Guess I should have looked at that first :)

 

http://msdn.microsoft.com/en-us/library/ms733768.aspx

 

FYI, when configuring the ip listen list, I added both 0.0.0.0:8000 and 127.0.0.1:8000. I kept getting errors until I added the second ip. Also, in the first step, you need to reserve both ExpenseService and ExpenseWorkflowService

Dec 3, 2009 at 5:45 PM

"I kept getting errors until I added the second ip. Also, in the first step, you need to reserve both ExpenseService and ExpenseWorkflowService"

Can you please give more info on how you did this.

Thanks.

Jan 31, 2010 at 12:12 AM

Hi, run as administrator work for me ...  with Vista.

gtcast.

Feb 23, 2010 at 6:37 PM

Thanks everyone.

I found the problem... It was shutting down the windows service after it was installed. Works fine now. Nice example.

Coordinator
Jun 24, 2010 at 7:03 AM

Just some things to check.

a) Are you running Visual Studio as the Administrator?

b) Is the sample able to run i.e. When you click Refresh, after you dismissed the errors? There is a tendency where the ConsoleHost takes a long time to initialize while the client loads up faster and immediately issue a refresh call to the host. This causes an error because the host has not yet being initialized. Once the host is initialized, all clients should work without problems.

c) Did you enabled WCF in your IIS? Is it configured properly?

d) Is your Windows Firewall blocking the port?

e) Are there more than one app using port 8000?