The type initializer for 'System.ServiceModel.Channels.Msmq' threw an exception.

Jan 6, 2009 at 12:22 PM
Hi,
I'm getting this error when i try to submit an expense. It may be related to a problem the service seems to be running into as I'm also getting another error - Could not connect to http://localhost:8000/ExpenseService. TCP error code 10061: No connection could be made because the target machine actively refused it 127.0.0.1:8000. I've disable msmq in my configuration files.

Brendan
Coordinator
Feb 8, 2009 at 8:54 AM
Hi Brendan,

Which version of the sample are you viewing?

MSMQ has been dropped in later versions of the sample. For older versions, you will need to disable MSMQ through the code in the host that you are running.

Hope it helps

Serena